Update to explicitly using jna-3.5.0.jar.

parent b497c03b
......@@ -2,10 +2,10 @@
;;;; Need to have jna.jar present for CFFI to have a chance of working.
(asdf:defsystem :jna
:version "3.4.0"
:version "3.5.0"
:defsystem-depends-on (jss abcl-asdf)
;; FIXME:
:components ((:mvn "net.java.dev.jna/jna/3.4.0")))
;; FIXME: always seems to be resolving the LATEST maven artifact.
:components ((:mvn "net.java.dev.jna/jna/3.5.0")))
(in-package :asdf)
(defmethod perform :after ((o load-op) (c (eql (find-system :jna))))
......@@ -23,8 +23,9 @@
(unless
(java:add-to-classpath (abcl-asdf:resolve "net.java.dev.jna:jna:3.4.0"))
(unless
(java:add-to-classpath #p"http://repo1.maven.org/maven2/net/java/dev/jna/jna/3.4.0/jna-3.4.0.jar")
(error "Failed to load jna-3.4.0.jar from the network via URI."))
;; Might want to download to local filesystem, then place in classpath
(java:add-to-classpath #p"http://repo1.maven.org/maven2/net/java/dev/jna/jna/3.5.0/jna-3.5.0.jar")
(error "Failed to load jna-3.5.0.jar from the network via URI."))
(error "Failed to load jna.jar via ABCL-ASDF.")))
(t (e)
(error "Failed to resolve 'jna.jar' because~&~A.~&" e))))
......
This diff is collapsed.
......@@ -4,8 +4,8 @@ build.xml.stylesheet.CRC32=be360661
# This file is used by a NetBeans-based IDE to track changes in generated files such as build-impl.xml.
# Do not edit this file. You may delete it but then the IDE will never regenerate such files for you.
nbproject/build-impl.xml.data.CRC32=742204ce
nbproject/build-impl.xml.script.CRC32=36361450
nbproject/build-impl.xml.stylesheet.CRC32=0ae3a408@1.44.1.45
nbproject/build-impl.xml.script.CRC32=1dc32654
nbproject/build-impl.xml.stylesheet.CRC32=6ddba6b6@1.53.1.46
nbproject/profiler-build-impl.xml.data.CRC32=71623fcd
nbproject/profiler-build-impl.xml.script.CRC32=abda56ed
nbproject/profiler-build-impl.xml.stylesheet.CRC32=42cb6bcf
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment