More documentation refresh for abcl-1.3.0-rc-0.

parent 43dbabe8
Version 1.3.0-dev
=================
Version 1.3.0-rc-0
==================
http://abcl.org/svn/trunk/abcl
Unreleased
## Features
* ASDF 3.0.3.0.1 shipped with the implementation
* ASDF 3.0.1.49 shipped with the implementation
* per function call stack and memory exception handler in CL:COMPILE
......@@ -24,13 +24,26 @@ Unreleased
* SYS:SHA256 audited
The functionality if the SYS:SHA256 algorithim has been audited for
use on inputs of single for files with recently shipping ORCL Java 7
implementations (through jdk-1.7.0_45).
The functionality if the SYS:SHA256 algorithim has been audited for
use on inputs of single for files with recently shipping ORCL Java 7
implementations (through jdk-1.7.0_51).
[r14582]: http://abcl.org/trac/changeset/14582
[r14582]: http://abcl.org/trac/changeset/14582
## Compatbility
* The Netbeans IDE configuration now includes a way to connect to the
running-under-jdb ABCL via SLIME. One needs to be able to load
things from 'swank.asd', which currently doesn't work in newer, more
github-ier SLIMEs.
* The Ant `abcl.mvn.install` target now installs build artifacts into
the local Maven repository (Olof-Joachim Frahm)
[r14579]: http://abcl.org/trac/changeset/14606
## Compatibility
* Tested: orcl-jdk-1.7.0_51 x64
### Contrib
......
......@@ -8,7 +8,7 @@
\begin{document}
\title{Armed Bear Common Lisp User Manual}
\date{Version 1.3.0-dev\\
\date{Version 1.3.0-rc-0\\
\smallskip
January 27, 2014}
\author{Mark Evenson \and Erik H\"{u}lsmann \and Rudolf Schlatte \and
......@@ -19,7 +19,8 @@ January 27, 2014}
\tableofcontents
\subsection{Preface to the Fourth Edition}
\textsc{ABCL} 1.3 now implements a lazily-created LispStack --The Mgmt.
\textsc{ABCL} 1.3 now implements an optimized implementation of the
LispStack abstraction thanks to Dmitry Nadezhin.
%%Preface to the Third edition, abcl-1.2.
\subsection{Preface to the Third Edition}
......@@ -1183,8 +1184,8 @@ code is greater than 0x00ff.
\section{Overloading of the CL:REQUIRE Mechanism}
The \code{CL:REQUIRE} mechanism is overloaded by attaching the following
semantic to the execution of \code{REQUIRE} on the following symbols:
The \code{CL:REQUIRE} mechanism is overloaded by attaching these
semantics to the execution of \code{REQUIRE} on the following symbols:
\begin{description}
......@@ -1205,7 +1206,7 @@ semantic to the execution of \code{REQUIRE} on the following symbols:
\begin{enumerate}
\item \code{abcl-asdf}
Functions for loading JVM artifacts
dynamically, hooking into ASDF 2 objects where possible.
dynamically, hooking into ASDF 3 objects where possible.
\item \code{asdf-jar}
Package addressable JVM artifacts via
\code{abcl-asdf} descriptions as a single binary artifact
......@@ -1215,7 +1216,7 @@ semantic to the execution of \code{REQUIRE} on the following symbols:
the distributed pom.xml graph of Maven Aether:
\begin{enumerate}
\item \code{jna}
Dynamically load 'jna.jar' version 3.5.1
Dynamically load 'jna.jar' version 4.0.0
from the network \footnote{This loading can be inhibited
if, at runtime, the Java class corresponding
``:classname'' clause of the system defition is present.}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment