Commit 3957fb00 authored by Francois-Rene Rideau's avatar Francois-Rene Rideau
Browse files

2.32.17: UIOP requires ASDF 2.011.4 or later. Accordingly fix upgrade tests.

parent dc236422
......@@ -74,7 +74,7 @@
:licence "MIT"
:description "Another System Definition Facility"
:long-description "ASDF builds Common Lisp software organized into defined systems."
:version "2.32.16" ;; to be automatically updated by make bump-version
:version "2.32.17" ;; to be automatically updated by make bump-version
:depends-on ()
#+asdf3 :encoding #+asdf3 :utf-8
;; For most purposes, asdf itself specially counts as a builtin system.
......
;;; -*- mode: Common-Lisp; Base: 10 ; Syntax: ANSI-Common-Lisp -*-
;;; This is ASDF 2.32.16: Another System Definition Facility.
;;; This is ASDF 2.32.17: Another System Definition Facility.
;;;
;;; Feedback, bug reports, and patches are all welcome:
;;; please mail to <asdf-devel@common-lisp.net>.
......
......@@ -523,9 +523,12 @@ is bound, write a message and exit on an error. If
(setf *package* (find-package :asdf-test))
t)
(defun load-asdf-lisp-and-test-uiop (&optional tag)
(load-asdf-lisp tag)
(unless (and (member :asdf *features*)
(or (member :asdf3 *features*)
(and (member :asdf2 *features*) (acall :version-satisfies (acall :asdf-version) "2.11.4"))))
(leave-test "UIOP will break ASDF < 2.011.4 - skipping test." 0))
(configure-asdf)
(register-directory *asdf-directory*)
(register-directory *uiop-directory*)
......
;;; -*- mode: lisp -*-
(in-package :asdf)
(unless (or (member :asdf3 *features*)
(and (member :asdf2 *features*) (version-satisfies (asdf:asdf-version) "2.11.4")))
(error "UIOP requires ASDF 2.011.4 or later."))
(defun call-without-redefinition-warnings (thunk)
(handler-bind (((or
#+allegro simple-warning
......
......@@ -52,7 +52,7 @@ You can compare this string with e.g.: (ASDF:VERSION-SATISFIES (ASDF:ASDF-VERSIO
;; "3.4.5.67" would be a development version in the official upstream of 3.4.5.
;; "3.4.5.0.8" would be your eighth local modification of official release 3.4.5
;; "3.4.5.67.8" would be your eighth local modification of development version 3.4.5.67
(asdf-version "2.32.16")
(asdf-version "2.32.17")
(existing-version (asdf-version)))
(setf *asdf-version* asdf-version)
(when (and existing-version (not (equal asdf-version existing-version)))
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment