Verified Commit e0121308 authored by Eric Timmons's avatar Eric Timmons
Browse files

Prevent spurious bad version string warnings when upgrading from <=3.3

We still ended up with the correct version number anyways, but just killing the
warnings completely makes it less likely the end user will thing something's
gone wrong.
parent 3d14cf27
Pipeline #5686 passed with stage
......@@ -23,7 +23,7 @@
;; and compulsory to sort them in defsystem-depends-on order.
#+asdf3
(defsystem "asdf/prelude"
:version (:read-file-form "full-version.lisp-expr")
:version #+asdf3.4 (:read-file-form "full-version.lisp-expr") #-asdf3.4 (:read-file-form "version.lisp-expr")
:around-compile call-without-redefinition-warnings ;; we need be the same as uiop
:encoding :utf-8
:components ((:file "header")))
......@@ -51,7 +51,7 @@
:bug-tracker "https://launchpad.net/asdf/"
:mailto "asdf-devel@common-lisp.net"
:source-control (:git "git://common-lisp.net/projects/asdf/asdf.git")
:version (:read-file-form "full-version.lisp-expr")
:version #+asdf3.4 (:read-file-form "full-version.lisp-expr") #-asdf3.4 (:read-file-form "version.lisp-expr")
:build-operation monolithic-concatenate-source-op
:build-pathname "build/asdf" ;; our target
:around-compile call-without-redefinition-warnings ;; we need be the same as uiop
......@@ -93,7 +93,10 @@
:licence "MIT"
:description "Another System Definition Facility"
:long-description "ASDF builds Common Lisp software organized into defined systems."
:version "3.4.0-alpha.1" ;; to be automatically updated by make bump-version
;; Having two :VERSION arguments makes the bump-version script a bit easier
;; to write for a non-Perl expert.
#+asdf3.4 :version #+asdf3.4 "3.4.0-alpha.1" ;; to be automatically updated by make bump-version
#-asdf3.4 :version #-asdf3.4 "3.4.0" ;; to be automatically updated by make bump-version
:depends-on ()
:components ((:module "build" :components ((:file "asdf"))))
. #-asdf3 () #+asdf3
......
......@@ -26,7 +26,8 @@ our @transform_ref =
[ "version.lisp-expr", "\"", "\"", 1],
[ "full-version.lisp-expr", "\"", "\"", 0],
[ "uiop/version.lisp", "(defparameter *uiop-version* \"", "\")", 0 ],
[ "asdf.asd", " :version \"", "\" ;; to be automatically updated by make bump-version", 0 ],
[ "asdf.asd", " #+asdf3.4 :version #+asdf3.4 \"", "\" ;; to be automatically updated by make bump-version", 0 ],
[ "asdf.asd", " #-asdf3.4 :version #-asdf3.4 \"", "\" ;; to be automatically updated by make bump-version", 1 ],
[ "header.lisp", "This is ASDF ", ": Another System Definition Facility.", 0 ],
[ "upgrade.lisp", "(asdf-version \"", "\")", 0 ],
[ "doc/asdf.texinfo", "Manual for Version ", "", 0 ], );
......
......@@ -49,4 +49,4 @@ you already have a matching UIOP loaded."
:around-compile call-without-redefinition-warnings
. #-asdf3.1 () #+asdf3.1
(:class package-system
:version (:read-file-form "version.lisp" :at (2 3 2)))))
:version #-asdf3.4 (:read-file-form "version.lisp" :at (2 2 2)) #+asdf3.4 (:read-file-form "version.lisp" :at (2 3 2)))))
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment