Commit 0409d059 authored by Robert P. Goldman's avatar Robert P. Goldman

Added a check for platforms that don't support the bundle op.

Currently, on Mac OSX, neither ABCL nor ECL passes the bundle-test, so
on these platform x implementation pairs, we issue a continuable error
when trying to use the BUNDLE-OP.
parent eae2eb54
......@@ -490,3 +490,11 @@
(defun bundle-system (system &rest args &key force (verbose t) version &allow-other-keys)
(declare (ignore force verbose version))
(apply #'operate 'binary-op system args)))
#+(and (not asdf-use-unsafe-mac-bundle-op)
(or (and ecl darwin) (and abcl darwin)))
(defmethod perform :before ((op bundle-op) c)
(declare (ignorable op c))
(unless (uiop:featurep :asdf-use-unsafe-mac-bundle-op)
(cerror "Continue after modifying *FEATURES*."
"The BUNDLE-OPs are not supported on Mac OSX for this lisp.~%~TTo continue, push :asdf-use-unsafe-mac-bundle-op on *FEATURES*.~%~TPlease report to ASDF-DEVEL if this works for you.")))
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment