Commit 11f15eb7 authored by Elias Pipping's avatar Elias Pipping

Do not exclude ECL <=16.0.1 if only 16.0.0 is broken

The check

  (lexicographic<= '< ver '(16 0 0))

Is equivalent to <=16.0.0. The argument '< gives the direction,
and should not be '<= here.
parent 2148e851
......@@ -1153,7 +1153,7 @@ or an indication of failure via the EXIT-CODE of the process"
#+(or clasp clisp) t
;; A race condition in ECL <= 16.0.0 prevents using ext:run-program
#+ecl #.(if-let (ver (parse-version (lisp-implementation-version)))
(lexicographic<= '< ver '(16 0 1)))
(lexicographic<= '< ver '(16 0 0)))
#+(and lispworks os-unix) (%interactivep input output error-output)
#+(or cormanlisp gcl (and lispworks os-windows) mcl xcl) t)
'%use-system '%use-launch-program)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment