Commit 6aa8bc70 authored by Peter Van Eynde's avatar Peter Van Eynde

also rebuild lisp images after install

parent 000f97e7
......@@ -2,9 +2,11 @@ cl-asdf (1.86-5) unstable; urgency=low
* Fixed duplicate components patch to better handle reloading
defsystem files. Now works again with McClim. Closes: #310640
* Corrected dependencies.
* Corrected dependencies.
* Added postinst rebuild of all clc-enabled lisps so the new version
actually gets loaded.
-- Peter Van Eynde <pvaneynd@debian.org> Wed, 25 May 2005 07:27:35 +0200
-- Peter Van Eynde <pvaneynd@debian.org> Wed, 25 May 2005 08:22:17 +0200
cl-asdf (1.86-4) unstable; urgency=low
......
#!/bin/bash
# postinst script for common-lisp-controller
#
# see: dh_installdeb(1)
set -e
# summary of how this script can be called:
# * <postinst> `configure' <most-recently-configured-version>
# * <old-postinst> `abort-upgrade' <new version>
# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
# <new-version>
# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
# <failed-install-package> <version> `removing'
# <conflicting-package> <version>
# for details, see /usr/share/doc/packaging-manual/
#
# quoting from the policy:
# Any necessary prompting should almost always be confined to the
# post-installation script, and should be protected with a conditional
# so that unnecessary prompting doesn't happen if a package's
# installation fails and the `postinst' is called with `abort-upgrade',
# `abort-remove' or `abort-deconfigure'.
. /usr/share/debconf/confmodule
case "$1" in
configure)
# We need to rebuild the images
for compiler in /usr/lib/common-lisp/bin/*.sh ; do
if [ -f "$compiler" -a -r "$compiler" ] ; then
i=${compiler##*/}
i=${i%.sh}
if [ -x "$compiler" ] ; then
echo Reinstalling for $i
echo Recompiling Common Lisp Controller for $i
bash "$compiler" install-clc || true
echo
echo Done rebuilding
fi
fi
done
;;
abort-upgrade|abort-remove|abort-deconfigure)
;;
*)
echo "postinst called with unknown argument \`$1'" >&2
exit 0
;;
esac
# dh_installdeb will replace this with shell code automatically
# generated by other debhelper scripts.
#DEBHELPER#
exit 0
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment