Commit e68eb145 authored by Robert Goldman's avatar Robert Goldman

Fix packaging of ADDITIONAL-INPUT-FILES.

Previously, this system was exported from component.lisp (and passed
through action.lisp), even though it's not used there.
Now it's simply exported from action.lisp.
Also, it's exported from interface.lisp.
parent e5c549db
...@@ -28,7 +28,6 @@ ...@@ -28,7 +28,6 @@
#:module-default-component-class #:module-default-component-class
#:module-components ;; backward-compatibility. DO NOT USE. #:module-components ;; backward-compatibility. DO NOT USE.
#:sub-components #:sub-components
#:additional-input-files
;; conditions ;; conditions
#:duplicate-names #:duplicate-names
......
...@@ -31,7 +31,8 @@ ...@@ -31,7 +31,8 @@
#:prepare-source-op #:load-source-op #:test-op #:define-op #:prepare-source-op #:load-source-op #:test-op #:define-op
#:feature #:version #:version-satisfies #:upgrade-asdf #:feature #:version #:version-satisfies #:upgrade-asdf
#:implementation-identifier #:implementation-type #:hostname #:implementation-identifier #:implementation-type #:hostname
#:input-files #:output-files #:output-file #:perform #:perform-with-restarts #:input-files #:additional-input-files
#:output-files #:output-file #:perform #:perform-with-restarts
#:operation-done-p #:explain #:action-description #:component-sideway-dependencies #:operation-done-p #:explain #:action-description #:component-sideway-dependencies
#:needed-in-image-p #:needed-in-image-p
#:component-load-dependencies #:run-shell-command ; deprecated, do not use #:component-load-dependencies #:run-shell-command ; deprecated, do not use
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment