Commit e69fdbdc authored by Francois-Rene Rideau's avatar Francois-Rene Rideau

2.30.1: make :utf-8 the *default-encoding*, not :default anymore.

It has vastly positive and nowhere negative outcome on cl-test-grid results:
	http://common-lisp.net/project/cl-test-grid/asdf/asdf-diff-14.html
Also, I've been warning people for almost a year now.
parent d116c6a4
......@@ -74,7 +74,7 @@
:licence "MIT"
:description "Another System Definition Facility"
:long-description "ASDF builds Common Lisp software organized into defined systems."
:version "2.30" ;; to be automatically updated by make bump-version
:version "2.30.1" ;; to be automatically updated by make bump-version
:depends-on ()
#+asdf3 :encoding #+asdf3 :utf-8
;; For most purposes, asdf itself specially counts as a builtin system.
......
cl-asdf (2:2.30-1) unstable; urgency=low
ASDF 2.29 is another bug fix release in preparation of an upcoming ASDF 3.
ASDF 2.30 is another bug fix release in preparation of an upcoming ASDF 3.
Since previous release 2.29, it includes:
* syntax around loading .asd files made more backward-compatible,
......@@ -19,16 +19,6 @@ cl-asdf (2:2.30-1) unstable; urgency=low
* exported symbols cleaned up somewhat.
* Compatibility with private use of :D package nickname
by not claiming it for package ASDF/DRIVER anymore.
Also explicitly handle NIL in safe-file-write-date,
in case the implementation doesn't issue a file-error in that case;
make UTF-8 the default encoding for with-input-file.
Be portable to #+(and sbcl (not sb-eval)).
* Bugfixes to old bugs: inline-methods can now be unqualified (lp#485393),
defsystem-depends-on accepts arbitrary specs, not just names (lp#1027521).
-- Francois-Rene Rideau <fare@tunes.org> Fri, 20 Feb 2013 17:53:32 -0500
cl-asdf (2:2.29-1) unstable; urgency=low
......
;;; -*- mode: Common-Lisp; Base: 10 ; Syntax: ANSI-Common-Lisp -*-
;;; This is ASDF 2.30: Another System Definition Facility.
;;; This is ASDF 2.30.1: Another System Definition Facility.
;;;
;;; Feedback, bug reports, and patches are all welcome:
;;; please mail to <asdf-devel@common-lisp.net>.
......
......@@ -43,10 +43,12 @@
;;; Encodings (mostly hooks only; full support requires asdf-encodings)
(with-upgradability ()
(defvar *default-encoding* :default
(defvar *default-encoding* :utf-8
"Default encoding for source files.
The default value :default preserves the legacy behavior.
A future default might be :utf-8 or :autodetect
The default value :utf-8 is the portable thing.
The legacy behavior was :default.
If you (load-system :asdf-encodings) then
you will have autodetection via *encoding-detection-hook*,
reading emacs-style -*- coding: utf-8 -*- specifications,
and falling back to utf-8 or latin1 if nothing is specified.")
......
......@@ -54,7 +54,7 @@
(with-encoding-test (:default)
(def-test-system :test-encoding-explicit-default
:components ((:file "lambda" :encoding :default))))
(with-encoding-test (:default)
(with-encoding-test (:utf-8)
(def-test-system :test-encoding-implicit-default
:components ((:file "lambda")))))
......
......@@ -52,7 +52,7 @@ You can compare this string with e.g.: (ASDF:VERSION-SATISFIES (ASDF:ASDF-VERSIO
;; "3.4.5.67" would be a development version in the official upstream of 3.4.5.
;; "3.4.5.0.8" would be your eighth local modification of official release 3.4.5
;; "3.4.5.67.8" would be your eighth local modification of development version 3.4.5.67
(asdf-version "2.30")
(asdf-version "2.30.1")
(existing-version (asdf-version)))
(setf *asdf-version* asdf-version)
(when (and existing-version (not (equal asdf-version existing-version)))
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment