Commit 0e621a9c authored by Francois-Rene Rideau's avatar Francois-Rene Rideau
Browse files

Issue deprecation warnings only at 3.4, not at 3.3

parent aca68cf1
...@@ -22,7 +22,7 @@ ...@@ -22,7 +22,7 @@
;; NB: the warning status of these functions may have to be distinguished later, ;; NB: the warning status of these functions may have to be distinguished later,
;; as some get removed faster than the others in client code. ;; as some get removed faster than the others in client code.
(with-asdf-deprecation (:style-warning "3.2") (with-asdf-deprecation (:style-warning "3.2" :warning "3.4")
;; These conditions from ASDF 1 and 2 are used by many packages in Quicklisp; ;; These conditions from ASDF 1 and 2 are used by many packages in Quicklisp;
;; but ASDF3 replaced them with somewhat different variants of uiop:compile-condition ;; but ASDF3 replaced them with somewhat different variants of uiop:compile-condition
......
...@@ -7,7 +7,7 @@ ...@@ -7,7 +7,7 @@
(:export #:load-sysdef)) (:export #:load-sysdef))
(in-package :asdf/backward-internals) (in-package :asdf/backward-internals)
(with-asdf-deprecation (:style-warning "3.2") (with-asdf-deprecation (:style-warning "3.2" :warning "3.4")
(defun load-sysdef (name pathname) (defun load-sysdef (name pathname)
(declare (ignore name pathname)) (declare (ignore name pathname))
;; Needed for backward compatibility with swank-asdf from SLIME 2015-12-01 or older. ;; Needed for backward compatibility with swank-asdf from SLIME 2015-12-01 or older.
......
...@@ -14,7 +14,7 @@ ...@@ -14,7 +14,7 @@
(in-package :uiop/backward-driver) (in-package :uiop/backward-driver)
(eval-when (:compile-toplevel :load-toplevel :execute) (eval-when (:compile-toplevel :load-toplevel :execute)
(with-deprecation ((version-deprecation *uiop-version* :style-warning "3.2")) (with-deprecation ((version-deprecation *uiop-version* :style-warning "3.2" :warning "3.4"))
;; Backward compatibility with ASDF 2.000 to 2.26 ;; Backward compatibility with ASDF 2.000 to 2.26
;; For backward-compatibility only, for people using internals ;; For backward-compatibility only, for people using internals
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment